Problem Installing DOTween Pro
« on: August 28, 2015, 06:02:49 AM »
I just purchased DOTween Pro and I'm very excited to start using it on my first project.  However after I installed it I get the following error:

Assets/Demigiant/DOTweenPro/Editor/DOTweenAnimationInspector.cs(262,22): error CS0266: Cannot implicitly convert type `LoopType' to `DG.Tweening.LoopType'. An explicit conversion exists (are you missing a cast?)

I don't have a lot of C# coding experience and so I'm not sure how to fix this.  I did have the free DOTween installed before to test it out but deleted it before I installed DOTween Pro but I'm not sure if something was left behind somewhere that might be causing this to happen.  I also have iTween installed as I was using that before discovering DOTween.

Thanks in advance for any help.


Re: Problem Installing DOTween Pro
« Reply #1 on: July 07, 2016, 10:44:56 PM »
This is also happening for me.
Just bought it from Asset Store, installed and same error appears.
I solved this making an explicit cast with full namespace, but doesn't really makes sense to me, since DG.Tweening namespace is already imported (using DG.Tweening) on the file header and no ambiguous type seems to exist.